Service Disruption - Pulseway- EU

Incident Report for Pulseway

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 13:42 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 10, 2026 - 10:33 EDT

Investigating

We are experiencing service disruption on a subset of Pulseway - EU servers, which may impact administrators' ability to manage endpoints.

We are aware of the issue, and our team is actively working to resolve the issue.

We apologize for any inconvenience caused.

- Cloud Operations Team
Posted Mar 10, 2026 - 09:10 EDT
This incident affected: SaaS - Europe.