Service Degradation - Pulseway- EU

Incident Report for Pulseway

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 13:45 EDT

Monitoring

We have added additional servers to Pulseway - EU region. We will continue to monitor the performance.

We apologize for any inconvenience caused.

- Cloud Operations Team
Posted Jun 30, 2025 - 17:44 EDT

Investigating

We are experiencing degraded performance on Pulseway - EU servers, which may impact administrators ability to manage endpoints.

We are aware of the issue and our team is actively working to resolve the issue.

We apologize for any inconvenience caused.

- Cloud Operations Team
Posted Jun 26, 2025 - 12:43 EDT
This incident affected: SaaS - Europe and Remote Control - Europe.